Page 1 of 1

Unity 2017 combatibility?

Posted: Thu Aug 17, 2017 7:38 pm
by hellhound_01
Recently I bought the Sci-Fi Design UI package. At the moment I try to get the demo scenes working using Unity 2017. I set up a new project and add only the DevDog asset. When I start the InGame Scene I got several compiler errors:

Code: Select all

NullReferenceException: Object reference not set to an instance of an object
UnityEngine.Experimental.UIElements.VisualContainer.LoadStyleSheetsFromPaths () (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:302)
UnityEditor.GUIView.get_panel () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:43)
UnityEditor.GUIView.get_visualTree () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:53)
UnityEditor.DockArea.OnEnable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:120)
UnityEditor.EditorWindow:GetWindow()
Devdog.SciFiDesign.Editors.SciFiDesignGettingStarted:InitializeOnLoadMethod() (at Assets/Devdog/SciFiDesign/FirstVersion/Scripts/Editor/SciFiDesignGettingStarted.cs:43)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()


Code: Select all

ArgumentException: This visualElement is not my child
UnityEngine.Experimental.UIElements.VisualContainer.RemoveChild (UnityEngine.Experimental.UIElements.VisualElement child) (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:216)
UnityEditor.DockArea.OnDisable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:153)
UnityEditor.EditorWindow:Close()
Devdog.SciFiDesign.Editors.SciFiDesignGettingStarted:InitializeOnLoadMethod() (at Assets/Devdog/SciFiDesign/FirstVersion/Scripts/Editor/SciFiDesignGettingStarted.cs:47)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()


And Warnings :
The referenced script on this Behaviour (Game Object 'RightBox') is missing! (3 times)

OnLevelWasLoaded was found on SciFiSceneLoaderHelper
This message has been deprecated and will be removed in a later version of Unity.
Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

I've reimported the asset multiple times, without any effect. I also found missings in the Settings Dialog.

Image

I tried any other Scene, they got also several Compiler warnings and errors. Is it possible to get this asset working without reviewing and fixing chunks of your code?