Good news! To provide faster support and grow the community, we'll be changing the forum to "Read Only" and turn to Discord instead for support.
Join here: https://discord.gg/zjNj5zZ

Unity 2017.1

User avatar
MaximilienLoGiudice
Posts: 87
Joined: Thu Dec 08, 2016 12:50 am

Unity 2017.1

Postby MaximilienLoGiudice » Wed Jul 19, 2017 1:07 pm

Hi Devdog :) How are you ?

I updated to Unity 2017.1

I m having these errors :

a.

Code: Select all

NullReferenceException: Object reference not set to an instance of an object
UnityEngine.Experimental.UIElements.VisualContainer.LoadStyleSheetsFromPaths () (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:302)
UnityEditor.GUIView.get_panel () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:43)
UnityEditor.GUIView.get_visualTree () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:53)
UnityEditor.DockArea.OnEnable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:120)
UnityEditor.EditorWindow:GetWindow()
Devdog.QuestSystemPro.Editors.GettingStartedEditor:InitializeOnLoadMethod() (at Assets/Devdog/QuestSystemPro/Scripts/Managers/Editor/GettingStartedEditor.cs:44)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()

b.

Code: Select all

ArgumentException: This visualElement is not my child
UnityEngine.Experimental.UIElements.VisualContainer.RemoveChild (UnityEngine.Experimental.UIElements.VisualElement child) (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:216)
UnityEditor.DockArea.OnDisable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:153)
UnityEditor.EditorWindow:Close()
Devdog.InventoryPro.Editors.GettingStartedEditor:InitializeOnLoadMethod() (at Assets/Devdog/InventoryPro/Scripts/Managers/Editor/GettingStartedEditor.cs:50)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()


When i start the .exe , i have some achievements windows which does not close.

Thx for your help.

Regards.

User avatar
jjahuijbregts
Site Admin
Posts: 2091
Joined: Wed Apr 22, 2015 7:25 pm
Contact:

Re: Unity 2017.1

Postby jjahuijbregts » Sat Jul 22, 2017 2:10 pm

MaximilienLoGiudice wrote:Hi Devdog :) How are you ?

I updated to Unity 2017.1

I m having these errors :

a.

Code: Select all

NullReferenceException: Object reference not set to an instance of an object
UnityEngine.Experimental.UIElements.VisualContainer.LoadStyleSheetsFromPaths () (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:302)
UnityEditor.GUIView.get_panel () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:43)
UnityEditor.GUIView.get_visualTree () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:53)
UnityEditor.DockArea.OnEnable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:120)
UnityEditor.EditorWindow:GetWindow()
Devdog.QuestSystemPro.Editors.GettingStartedEditor:InitializeOnLoadMethod() (at Assets/Devdog/QuestSystemPro/Scripts/Managers/Editor/GettingStartedEditor.cs:44)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()

b.

Code: Select all

ArgumentException: This visualElement is not my child
UnityEngine.Experimental.UIElements.VisualContainer.RemoveChild (UnityEngine.Experimental.UIElements.VisualElement child) (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:216)
UnityEditor.DockArea.OnDisable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:153)
UnityEditor.EditorWindow:Close()
Devdog.InventoryPro.Editors.GettingStartedEditor:InitializeOnLoadMethod() (at Assets/Devdog/InventoryPro/Scripts/Managers/Editor/GettingStartedEditor.cs:50)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()


When i start the .exe , i have some achievements windows which does not close.

Thx for your help.

Regards.


Hi, thanks for letting me know; I'll look into this shortly.

The first error comes from the Unity method call GetWindow<>() which might actually be an error on Unity's end.

User avatar
bsimser
Posts: 4
Joined: Tue Nov 22, 2016 12:54 am

Re: Unity 2017.1

Postby bsimser » Mon Aug 07, 2017 12:30 pm

Any update on this? I just updated to 2017.1.0f3 and getting the same error. The system *seems* to work, but I get these three errors in my console on startup.

Code: Select all

NullReferenceException: Object reference not set to an instance of an object
UnityEngine.Experimental.UIElements.VisualContainer.LoadStyleSheetsFromPaths () (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:302)
UnityEditor.GUIView.get_panel () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:43)
UnityEditor.GUIView.get_visualTree () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:53)
UnityEditor.DockArea.OnEnable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:120)
UnityEditor.EditorWindow:GetWindow()
Devdog.InventoryPro.Editors.GettingStartedEditor:InitializeOnLoadMethod() (at Assets/Devdog/InventoryPro/Scripts/Managers/Editor/GettingStartedEditor.cs:46)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()


Then

Code: Select all

ArgumentException: This visualElement is not my child
UnityEngine.Experimental.UIElements.VisualContainer.RemoveChild (UnityEngine.Experimental.UIElements.VisualElement child) (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:216)
UnityEditor.DockArea.OnDisable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:153)
UnityEditor.EditorWindow:Close()
Devdog.InventoryPro.Editors.GettingStartedEditor:InitializeOnLoadMethod() (at Assets/Devdog/InventoryPro/Scripts/Managers/Editor/GettingStartedEditor.cs:50)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()


Next one

Code: Select all

NullReferenceException: Object reference not set to an instance of an object
UnityEngine.Experimental.UIElements.VisualContainer.LoadStyleSheetsFromPaths () (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:302)
UnityEditor.GUIView.get_panel () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:43)
UnityEditor.GUIView.get_visualTree () (at C:/buildslave/unity/build/Editor/Mono/GUIView.cs:53)
UnityEditor.DockArea.OnEnable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:120)
UnityEditor.EditorWindow:GetWindow()
Devdog.QuestSystemPro.Editors.GettingStartedEditor:InitializeOnLoadMethod() (at Assets/Devdog/QuestSystemPro/Scripts/Managers/Editor/GettingStartedEditor.cs:44)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()


Finally

Code: Select all

ArgumentException: This visualElement is not my child
UnityEngine.Experimental.UIElements.VisualContainer.RemoveChild (UnityEngine.Experimental.UIElements.VisualElement child) (at C:/buildslave/unity/build/Runtime/UIElements/Managed/VisualContainer.cs:216)
UnityEditor.DockArea.OnDisable () (at C:/buildslave/unity/build/Editor/Mono/GUI/DockArea.cs:153)
UnityEditor.EditorWindow:Close()
Devdog.QuestSystemPro.Editors.GettingStartedEditor:InitializeOnLoadMethod() (at Assets/Devdog/QuestSystemPro/Scripts/Managers/Editor/GettingStartedEditor.cs:48)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()


I have both InventoryPro and Quest Pro installed.

Thanks


Return to “Programming”

Who is online

Users browsing this forum: No registered users and 1 guest